Tag: gcc

Befehl 'gcc' fehlgeschlagen mit Exit Status 1 bei der Installation von cx_Oracle auf Windows 64 Bit

Ich versuche, cx_Oracle auf meiner Windows 7 – 64 Bit Version zu installieren. Ich hatte vorher eine Frage hier über die Installation von cx_Oracle auf Windows und ich löste das Problem von mir selbst; Aber es war eine 32-Bit-Version von Windows 7; Hier habe ich ein neues problem aufgestellt Ich sollte erwähnen, dass ich 64-Bit-Version […]

Gcc-4.0 Fehler beim Aufbau _imaging Erweiterung für PIL

Wenn ich PIL (oder Kissen) installiere, wird das Modul _imaging C nicht installiert. Dies ist ein häufiger Fehler und haben die Play-by-Play-Lösung von ApPeL gesehen, die die meisten hilfreich gefunden haben. Leider, wenn ich sudo python setup.py install , bekomme ich die folgende sudo python setup.py install : running install running build running build_py running […]

Legen Sie Umgebungsvariablen für den gcc-Compiler fest

Ich möchte Umgebungsvariablen für meinen gcc-Compiler setzen. Speziell möchte ich eine dieser beiden Flags setzen: -fPIC Positionsunabhängiger Code generieren, wenn möglich (großer Modus) -fPIE Erzeugungspositionsunabhängiger Code für ausführbare Dateien, wenn möglich (großer Modus) Welche Umgebungsvariablen muss ich vor der Code-Kompilierung setzen, damit diese Flags aktiviert sind? Grundsätzlich, was ich will, ist meine setup.py-Datei, die ich […]

Compilerfehler bei der Installation von Python-Initialen: Warnungen als Fehler behandelt

Versuche, python-igraph mit pip für Python 3 zu installieren, bekomme ich den folgenden Compiler-Fehler. Kann ich etwas ändern oder ist das ein Fehler in igraph? Beachten Sie die Zeile cc1: some warnings being treated as errors am Ende behandelt – wenn sie nur Warnungen sind, kann ich sie einfach ignorieren? Extracting igraph-0.7.0.tar.gz… Configuring igraph… Build […]

Libpython2.7.a fehlen viele referenzen

Ich versuche, ein cython Modul mit -static zu kompilieren, aber ich -static eine Menge Fehler über fehlende Referenzen in libpython2.7.a . Beispielsweise: /usr/lib/x86_64-linux-gnu/libpython2.7.a(complexobject.o): In function `_Py_c_pow': (.text.unlikely+0x507): undefined reference to `pow' Ich habe bereits das Paket build-essential installiert, was ist eine Lösung, die ich bei Google gefunden habe. Mein Arbeitsablauf ist: cython –embed hi.py gcc […]

Pillow virtualenv install schlägt fehl: "command 'gcc-4.2' failed" [duplicate]

Diese Frage hat hier schon eine Antwort: Gcc-4.2 fehlgeschlagen mit Exit-Status 1 7 Antworten Ich installiere Mezzanine in einem virtualenv. Es scheitert an der Kissen- Installation mit einem gcc-4.2 verwandten Fehler, von denen dies ein Auszug ist. Ich kann es wirklich erfolgreich auf meiner Maschine installieren, aber nicht innerhalb eines virtualenv. Ich will es in […]

Gevent kann in einer virtuellen python-Umgebung auf OS X Capitan nicht installiert werden

Ich habe gerade OS X Capitan installiert und versucht, gevent in einer virtuellen Umgebung von python2.7.x zu installieren. Und hier bekomme ich Sieht aus wie etwas mit gcc. Hier ist der Rückblick: Building wheels for collected packages: gevent Running setup.py bdist_wheel for gevent Complete output from command /Users/admin/pyenvs/plgrnd/bin/python -c "import setuptools;__file__='/private/var/folders/m8/xt5420594cn8zbgnry594ljw0000gn/T/pip-build-KkzbuJ/gevent/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" bdist_wheel […]

Nicht erkannte Befehlszeilenoption '-rdynamic' auf GCC v4.9.2

Ich benutze GCC v4.9.2 unter Cygwin auf Windows 7 64-Bit, aber läuft in ein Problem, das versucht, uWSGI zu kompilieren. Der Fehler, den ich empfange, ist – gcc: error: unrecognized command line option '-rdynamic' GCC-Versionsausgabe – $ gcc -v Using built-in specs. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-cygwin/4.9.2/lto-wrapper.exe Target: x86_64-pc-cygwin Configured with: /cygdrive/i/szsz/tmpp/gcc/gcc-4.9.2-3.x86_64/src/gcc-4.9.2/configure –srcdir=/cygdrive/i/szsz/tmpp/gcc/gcc-4.9.2-3.x86_64/src/gcc-4.9.2 –prefix=/usr –exec-prefix=/usr –bindir=/usr/bin –sbindir=/usr/sbin –libexecdir=/usr/libexec […]

Auswählen der GCC-Version beim Aufbau (setup.py)

Ich versuche, ein Python-Modul (scikit.timeseries) mit zu bauen python setup.py build Aber es fällt aus wie folgt: /Versions/2.6/lib/python2.6/site-packages/numpy/core/include -I/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -c' gcc-4.0: scikits/timeseries/src/cseries.c sh: gcc-4.0: command not found Dies ist, weil ich auf OSX Lion und gcc-4.0 nicht beenden, gcc tut zwar: gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.0 Aber es […]

Pillow-Fehler installieren: Setup-Skript mit Fehler beendet: Befehl 'x86_64-linux-gnu-gcc' fehlgeschlagen mit Exit-Status 1

Während ich versuche zu installieren Pillow 2.5.3 Ich bekomme einen Fehler: Befehl 'x86_64-linux-gnu-gcc' fehlgeschlagen mit Exit-Status 1 Hier ist das komplette Protokoll von dem, was passiert ist Ich brauche diese Bibliothek als Teil eines anderen Pythonprojektes. Ich habe viele Lösungen durchgemacht, aber keiner hat mir geholfen

Python ist die beste Programmiersprache der Welt.